Browse Source

remove 0.11.1-r3 (not needed anymore)

tags/v0.115.0_beta6
Andreas Billmeier 1 month ago
committed by Andreas Billmeier
parent
commit
260065db7d
Signed by: onkelbeh GPG Key ID: E6DB12C8C550F3C0
4 changed files with 1 additions and 125 deletions
  1. +1
    -0
      CHANGELOG.txt
  2. +0
    -3
      net-analyzer/fail2ban/Manifest
  3. +0
    -111
      net-analyzer/fail2ban/fail2ban-0.11.1-r3.ebuild
  4. +0
    -11
      net-analyzer/fail2ban/metadata.xml

+ 1
- 0
CHANGELOG.txt View File

@@ -1,6 +1,7 @@
2020-09-12
* bump pyloopenergy-0.2.1
* update homeassistant-0.115.0_beta6
* remove 0.11.1-r3 (not needed anymore)

2020-09-11 homeassistant-0.115.0_beta5
* bump numpy-1.19.2


+ 0
- 3
net-analyzer/fail2ban/Manifest View File

@@ -1,3 +0,0 @@
DIST fail2ban-0.11.1.tar.gz 538660 BLAKE2B c88765ac3f49c19e0570248891814c647f2c3515290982de21c7b6c377508189fa53182fca84d62f61b231e250395992e8cf06cc61394dd41150f02d8a254f8b SHA512 019b088aa6375f98742ed101ef6f65adabca3324444d71d5b8597a8d1d22fa76b9f503660f0498643fe24a3b8e4368de916072a1ab77b8e2ea3eda41c3e0c8c6
EBUILD fail2ban-0.11.1-r3.ebuild 3344 BLAKE2B 17aa0ee7bb0f6b7d89472502547af08652e97ce715a5e668227755f5a4d5a102af1d0e2a6a7f8446e3eb34d04d5dd98cfb7fa35051a9bba9c80a20507b30af93 SHA512 79f1eb053baf13956a91fe2894819adf39396a29c9a654ed1a33ae546a137da6b2269186466f93c5d73db567973d0021c15f746e5ea9de2edbb987d107822d2c
MISC metadata.xml 372 BLAKE2B 7fca866187d9a128e6fb6787a4099d7a6442e0e51e558786773b91c3e2f06e67167d76f9bc96be0fe1baa1c44fc3f0e9e2105a327a10cb2720b3e3f9e4303a66 SHA512 4d5710e2fb4a7c353ca6bd3203bceef57d4d004367993dc1044800ee8713a3f4697fe8ba3472a73ecd015503656dfb7cd68d674c99188ce5702769cfeaf06b25

+ 0
- 111
net-analyzer/fail2ban/fail2ban-0.11.1-r3.ebuild View File

@@ -1,111 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_SINGLE_IMPL=1

inherit bash-completion-r1 distutils-r1 systemd

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="selinux systemd"

RDEPEND="
virtual/logger
virtual/mta
selinux? ( sec-policy/selinux-fail2ban )
systemd? ( $(python_gen_cond_dep '|| (
dev-python/python-systemd[${PYTHON_MULTI_USEDEP}]
sys-apps/systemd[python(-),${PYTHON_MULTI_USEDEP}]
)' 'python*' ) )
"

RESTRICT="test"
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

python_prepare_all() {
default

# Replace /var/run with /run, but not in the top source directory
find . -mindepth 2 -type f -exec \
sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die

sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die

distutils-r1_python_prepare_all
}

python_compile() {
if python_is_python3; then
./fail2ban-2to3 || die
fi
distutils-r1_python_compile
}

python_install_all() {
distutils-r1_python_install_all

rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run || die

# not FILESDIR
newconfd files/gentoo-confd ${PN}
newinitd files/gentoo-initd ${PN}
sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
systemd_dounit "${T}/${PN}.service"
systemd_dotmpfilesd files/${PN}-tmpfiles.conf
doman man/*.{1,5}

# Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
# See https://thread.gmane.org/gmane.linux.gentoo.devel/35675
insinto /etc/logrotate.d
newins files/${PN}-logrotate ${PN}

keepdir /var/lib/${PN}

newbashcomp files/bash-completion ${PN}-client
bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
}

pkg_preinst() {
has_version "<${CATEGORY}/${PN}-0.7"
previous_less_than_0_7=$?
}

pkg_postinst() {
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
elog "files before restarting Fail2ban!"
elog
elog "Fail2ban is not installed under /usr/lib anymore. The"
elog "new location is under /usr/share."
elog
elog "You are upgrading from version 0.6.x, please see:"
elog "https://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi

if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
elog "For most jail.conf configurations, it is recommended you install either"
elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
elog "to control how log file modifications are detected"
fi

if ! has_version dev-lang/python[sqlite]; then
elog "If you want to use ${PN}'s persistent database, then reinstall"
elog "dev-lang/python with USE=sqlite. If you do not use the"
elog "persistent database feature, then you should set"
elog "dbfile = :memory: in fail2ban.conf accordingly."
fi

if has_version sys-apps/systemd[-python]; then
elog "If you want to track logins through sys-apps/systemd's"
elog "journal backend, then reinstall sys-apps/systemd with USE=python"
fi
}

+ 0
- 11
net-analyzer/fail2ban/metadata.xml View File

@@ -1,11 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>netmon@gentoo.org</email>
<name>Gentoo network monitoring and analysis project</name>
</maintainer>
<upstream>
<remote-id type="github">fail2ban/fail2ban</remote-id>
</upstream>
</pkgmetadata>

Loading…
Cancel
Save