GentooRepository/dev-perl/Exception-Class/Exception-Class-1.450.0.ebuild

30 lines
733 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=DROLSKY
DIST_VERSION=1.45
DIST_EXAMPLES=("bench/*")
inherit perl-module
DESCRIPTION="Module that allows you to declare real exception classes in Perl"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-perl/Class-Data-Inheritable-0.20.0
>=dev-perl/Devel-StackTrace-2.0.0
virtual/perl-Scalar-List-Utils
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-File-Spec
>=virtual/perl-Test-Simple-0.960.0
)
"