monitoring/dev-python/django-tagging/django-tagging-0.5.0.ebuild

46 lines
1.0 KiB
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Generic tagging application for Django"
HOMEPAGE="https://github.com/Fantomas42/django-tagging https://pypi.org/project/django-tagging/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test docs"
RDEPEND=">=dev-python/django-1.0[${PYTHON_USEDEP}]"
DEPEND="${REDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
)"
python_test() {
nosetests --verbose || die
py.test -v -v || die
}
python_prepare_all() {
sed -i "/sphinx.ext.intersphinx/d" docs/conf.py || die
distutils-r1_python_prepare_all
}
python_compile_all() {
if use doc; then
sphinx-build docs docs/_build/html || die
HTML_DOCS=( docs/_build/html/. )
fi
}