monitoring/dev-python/django-recaptcha/django-recaptcha-2.0.6.ebuild

33 lines
837 B
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Django recaptcha form field/widget app."
HOMEPAGE="http://github.com/praekelt/django-recaptcha https://pypi.org/project/django-recaptcha/"
SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
DEPEND="${REDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/django-setuptest-0.2.1[${PYTHON_USEDEP}]
)"
python_test() {
nosetests --verbose || die
py.test -v -v || die
esetup.py test || die
}