HomeAssistantRepository/dev-python/transmissionrpc/transmissionrpc-0.11.ebuild

28 lines
626 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python module that implements the Transmission bittorent client RPC protocol."
HOMEPAGE="https://bitbucket.org/blueluna/transmissionrpc https://pypi.org/project/transmissionrpc/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest