HomeAssistantRepository/dev-python/regenmaschine/regenmaschine-2024.3.0.ebuild

35 lines
940 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=poetry
inherit distutils-r1 pypi
DESCRIPTION="A simple API for RainMachine sprinkler controllers"
HOMEPAGE="https://github.com/bachya/regenmaschine https://pypi.org/project/regenmaschine/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND=">=dev-python/aiohttp-3.8.0[${PYTHON_USEDEP}]
>=dev-python/certifi-2023.7.22[${PYTHON_USEDEP}]
>=dev-python/frozenlist-1.4.0[${PYTHON_USEDEP}]
>=dev-python/yarl-1.9.2[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/aresponses[${PYTHON_USEDEP}]
dev-python/asynctest[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
)"
distutils_enable_tests pytest