HomeAssistantRepository/dev-python/python-nest/python-nest-4.2.0.ebuild

34 lines
827 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1 pypi
DESCRIPTION="Python API and command line tool for talking to the Nest Thermostat"
HOMEPAGE="https://github.com/jkoelker/python-nest/ https://pypi.org/project/python-nest/"
LICENSE="CC-BY-NC-SA-3.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
dev-python/sseclient-py[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest