HomeAssistantRepository/dev-python/pymediaroom/pymediaroom-0.6.5.4.ebuild

25 lines
587 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Remote control your Mediaroom Set-up-box"
HOMEPAGE="https://github.com/dgomes/pymediaroom https://pypi.org/project/pymediaroom/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND="dev-python/async-timeout[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]"
distutils_enable_tests pytest