HomeAssistantRepository/dev-python/pymailgunner/pymailgunner-1.4.ebuild

24 lines
583 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="A simple mailgun client - pymailgun fork with Python 3 support"
HOMEPAGE="https://github.com/pschmitt/pymailgunner https://pypi.org/project/pymailgunner/"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
#DOCS="README.md"
RDEPEND=">=dev-python/requests-2.2.1[${PYTHON_USEDEP}]"
distutils_enable_tests pytest