HomeAssistantRepository/dev-python/pylutron/pylutron-0.2.12.ebuild

22 lines
483 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python library for Lutron RadioRA 2"
HOMEPAGE="https://github.com/thecynic/pylutron https://pypi.org/project/pylutron/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
distutils_enable_tests pytest