HomeAssistantRepository/dev-python/pylgnetcast/pylgnetcast-0.3.7.ebuild

24 lines
558 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Client for the LG Smart TV running NetCast 3 or 4."
HOMEPAGE="https://github.com/Drafteed/python-lgnetcast https://pypi.org/project/pylgnetcast/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
distutils_enable_tests pytest