HomeAssistantRepository/dev-python/pyiss/pyiss-1.0.1.ebuild

27 lines
760 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="A simple python3 library for info about the current International Space Station location"
HOMEPAGE="https://github.com/HydrelioxGitHub/pyiss https://pypi.org/project/pyiss/"
SRC_URI="https://github.com/HydrelioxGitHub/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/httmock[${PYTHON_USEDEP}]
dev-python/voluptuous[${PYTHON_USEDEP}]"
distutils_enable_tests pytest