HomeAssistantRepository/dev-python/pyforked-daapd/pyforked-daapd-0.1.14.ebuild

25 lines
562 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1 pypi
DESCRIPTION="Python Interface for forked-daapd"
HOMEPAGE="https://github.com/uvjustin/pyforked-daapd/ https://pypi.org/project/pyforked-daapd/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]"
distutils_enable_tests pytest