HomeAssistantRepository/dev-python/pyfnip/pyfnip-0.2.ebuild

24 lines
544 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python wrapper for FutureNow IP relay/dimmer units"
HOMEPAGE="https://github.com/juhaniemi/pyfnip https://pypi.org/project/pyfnip/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
distutils_enable_tests pytest