HomeAssistantRepository/dev-python/pyebox/pyebox-1.1.4.ebuild

25 lines
588 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Get your EBox consumption (wwww.ebox.ca)"
HOMEPAGE="https://github.com/titilambert/pyebox https://pypi.org/project/pyebox/"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]"
distutils_enable_tests pytest