HomeAssistantRepository/dev-python/pycsspeechtts/pycsspeechtts-1.0.8.ebuild

24 lines
585 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1 pypi
DESCRIPTION="Python 3 interface to Microsoft Cognitive Services Text To Speech"
HOMEPAGE="https://github.com/jeroenterheerdt/pycsspeechtts https://pypi.org/project/pycsspeechtts/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
#DOCS="README.md"
RDEPEND=">=dev-python/requests-2.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest