HomeAssistantRepository/dev-python/pycocotools/pycocotools-2.0.6.ebuild

25 lines
575 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Official APIs for the MS-COCO dataset"
HOMEPAGE="https://github.com/ppwwyyxx/cocoapi https://pypi.org/project/pycocotools/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
#DOCS="README.md"
RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]"
distutils_enable_tests pytest