HomeAssistantRepository/dev-python/pycmus/pycmus-0.1.1.ebuild

23 lines
535 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="A python cmus remote library"
HOMEPAGE="https://github.com/mtreinish/pycmus https://pypi.org/project/pycmus/"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
distutils_enable_tests pytest