HomeAssistantRepository/dev-python/pycketcasts/pycketcasts-1.0.1.ebuild

30 lines
657 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Interact with PocketCast's unofficial API"
HOMEPAGE="https://github.com/nwithan8/pycketcasts https://pypi.org/project/pycketcasts/"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/python-magic[${PYTHON_USEDEP}]"
src_prepare() {
echo "requests" > requirements.txt
eapply_user
}
distutils_enable_tests pytest