HomeAssistantRepository/dev-python/pyarlo/pyarlo-0.2.4.ebuild

33 lines
758 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python Arlo is a library written in Python 2.7/3x that exposes the Netgear Arlo cameras as Python objects."
HOMEPAGE="https://github.com/tchellomello/python-arlo https://pypi.org/project/pyarlo/"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/sseclient-py[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest