HomeAssistantRepository/dev-python/pyHik/pyHik-0.3.2.ebuild

33 lines
729 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Provides a python api to interact with a Hikvision camera event stream and toggle motion detection."
HOMEPAGE="https://github.com/mezz64/pyhik https://pypi.org/project/pyHik/"
SRC_URI="https://github.com/mezz64/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest