HomeAssistantRepository/dev-python/openhomedevice/openhomedevice-2.2.ebuild

33 lines
739 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Provides an API for requesting information from an Openhome device"
HOMEPAGE="https://github.com/bazwilliams/openhomedevice https://pypi.org/project/openhomedevice/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND=">=dev-python/async-upnp-client-0.27[${PYTHON_USEDEP}]
>=dev-python/lxml-4.8.0[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest