HomeAssistantRepository/dev-python/nextcloudmonitor/nextcloudmonitor-1.5.0.ebuild

23 lines
557 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python wrapper around nextcloud monitor api"
HOMEPAGE="https://github.com/meichthys/nextcloud_monitor https://pypi.org/project/nextcloudmonitor/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
distutils_enable_tests pytest