HomeAssistantRepository/dev-python/netdata/netdata-1.1.0.ebuild

33 lines
688 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=poetry
inherit distutils-r1 pypi
DESCRIPTION="Python API for interacting with Netdata."
HOMEPAGE="https://github.com/fabaff/python-netdata https://pypi.org/project/netdata/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND=">=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
>=dev-python/yarl-1.8.0[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest