HomeAssistantRepository/dev-python/minio/minio-7.1.12.ebuild

33 lines
707 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="MinIO Python Library for Amazon S3 Compatible Cloud Storage for Python"
HOMEPAGE="https://github.com/minio/minio-py https://pypi.org/project/minio/"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/certifi[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest