HomeAssistantRepository/dev-python/micloud/micloud-0.5.ebuild

34 lines
741 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Xiaomi cloud connect library"
HOMEPAGE="https://github.com/squachen/micloud https://pypi.org/project/micloud/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
dev-python/tzlocal[${PYTHON_USEDEP}]
dev-python/click[${PYTHON_USEDEP}]
dev-python/pycryptodome[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest