HomeAssistantRepository/dev-python/horimote/horimote-0.4.1.ebuild

32 lines
695 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Async API wrapper for Samsumgs set-top boxes SMT-G7400 and SMT-G7401."
HOMEPAGE="https://github.com/benleb/horimote https://pypi.org/project/horimote/"
SRC_URI="https://github.com/benleb/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest