HomeAssistantRepository/dev-python/holidays/holidays-0.46.ebuild

22 lines
524 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Generate and work with holidays in Python"
HOMEPAGE="https://github.com/dr-prodigy/python-holidays https://pypi.org/project/holidays/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"