HomeAssistantRepository/dev-python/hdate/hdate-0.10.4.ebuild

33 lines
687 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=poetry
inherit distutils-r1 pypi
DESCRIPTION="Jewish/Hebrew date and Zmanim in native Python"
HOMEPAGE="https://github.com/py-libhdate/py-libhdate https://pypi.org/project/hdate/"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/astral-2.2[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest