HomeAssistantRepository/dev-python/gps3/gps3-0.33.3-r1.ebuild

34 lines
737 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Python 2.7-3.5 clients for gpsd"
HOMEPAGE="https://github.com/wadda/gps3 https://pypi.org/project/gps3/"
COMMIT="91adcd7073b891b135b2a46d039ce2125cf09a09"
SRC_URI="https://github.com/wadda/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="DESCRIPTION.rst"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest