HomeAssistantRepository/dev-python/fjaraskupan/fjaraskupan-2.3.0.ebuild

29 lines
660 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="A python library for speaking to fjäråskupan"
HOMEPAGE="https://github.com/elupus/fjaraskupan https://pypi.org/project/fjaraskupan/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
RDEPEND=">=dev-python/bleak-0.19[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
)"
distutils_enable_tests pytest