HomeAssistantRepository/dev-python/crccheck/crccheck-1.3.0.ebuild

22 lines
500 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Calculation library for CRCs and checksums"
HOMEPAGE="https://github.com/MartinScharrer/crccheck https://pypi.org/project/crccheck/"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.rst"
distutils_enable_tests pytest