HomeAssistantRepository/dev-python/circuit-webhook/circuit-webhook-1.0.1.ebuild

22 lines
567 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1 pypi
DESCRIPTION="circuit-webhook is a python client library for Unify Circuit api"
HOMEPAGE="https://github.com/braam/unify/tree/master/circuit-webhook-python https://pypi.org/project/circuit-webhook/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
distutils_enable_tests pytest