HomeAssistantRepository/dev-python/broadlink/broadlink-0.18.3.ebuild

23 lines
556 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python API for controlling Broadlink devices"
HOMEPAGE="https://github.com/mjg59/python-broadlink https://pypi.org/project/broadlink/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND=">=dev-python/cryptography-3.2[${PYTHON_USEDEP}]"
distutils_enable_tests pytest