HomeAssistantRepository/dev-python/bravia-tv/bravia-tv-1.0.11.ebuild

23 lines
540 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python Bravia TV remote control"
HOMEPAGE="https://github.com/dcnielsen90/python-bravia-tv/ https://pypi.org/project/bravia-tv/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
distutils_enable_tests pytest