HomeAssistantRepository/dev-python/adb-homeassistant/adb-homeassistant-1.3.2.ebuild

33 lines
717 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1 pypi
DESCRIPTION="A pure python implementation of the Android ADB and Fastboot protocols"
HOMEPAGE="https://github.com/google/python-adb"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/libusb1-1.0.16[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)
"
python_test() {
py.test -v || die "Tests failed under ${EPYTHON}"
}
distutils_enable_tests pytest