HomeAssistantRepository/dev-python/accuweather/accuweather-2.1.1.ebuild

36 lines
888 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
DESCRIPTION="Python wrapper for getting weather data from AccuWeather servers."
HOMEPAGE="https://github.com/bieniu/accuweather https://pypi.org/project/accuweather/"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND=">=dev-python/aiohttp-3.7.0[${PYTHON_USEDEP}]
dev-python/orjson[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/pytest-runner[${PYTHON_USEDEP}]
test? (
dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest