HomeAssistantRepository/dev-python/WSDiscovery/WSDiscovery-2.0.0.ebuild

34 lines
751 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1 pypi
DESCRIPTION="WS-Discovery implementation for python"
HOMEPAGE="https://github.com/andreikop/python-ws-discovery.git https://pypi.org/project/WSDiscovery/"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
DOCS="README.md"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/netifaces[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest