HomeAssistantRepository/dev-python/OPi-GPIO/OPi-GPIO-0.5.2.ebuild

30 lines
626 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
inherit distutils-r1 pypi
DESCRIPTION="A drop-in replacement for RPi.GPIO for the Orange Pi Zero"
HOMEPAGE="https://github.com/rm-hull/OPi.GPIO https://pypi.org/project/OPi.GPIO/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v -v || die
}
distutils_enable_tests pytest