homeassistant-min depends on removed dev-python/google-api-core version ~1.31.2 #243

Closed
opened 2 months ago by Tatsh · 0 comments
Tatsh commented 2 months ago
Calculating dependencies... done!
[ebuild     U  ] dev-python/google-api-core-2.0.1::gentoo [1.31.2::gentoo] USE="-test" PYTHON_TARGETS="python3_9 -python3_8" 132 KiB

Total: 1 package (1 upgrade), Size of downloads: 132 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/google-api-core:0

  (dev-python/google-api-core-2.0.1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -python3_8" pulled in by
    dev-python/google-api-core (Argument)

  (dev-python/google-api-core-1.31.2:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_9 -python3_8" pulled in by
    ~dev-python/google-api-core-1.31.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (app-misc/homeassistant-min-2021.10.0:0/0::HomeAssistantRepository, installed) USE="accuweather airly airvisual alpha_vantage android_ip_webcam androidtv bluetooth_le_tracker caldav cast cli coronavirus dwd_weather_warnings github homekit homekit_controller http kodi mobile_app mqtt myq mysql notify_events otp ping python_script recorder rest ring scrape snmp speedtestdotnet sql ssl systemd systemmonitor tile tplink version wake_on_lan wemo whois zeroconf zwave_js -axis -camera -co2signal -compensation -darksky -enigma2 -esphome -forecast_solar -fronius -hyperion -influxdb -knx -kraken -maxcube -mikrotik -mysensors -owntracks -ozw -plex -ps4 -qnap -qvr_pro -samsungtv -season -shelly -signal_messenger -socat -sonos -tasmota -test -tradfri -utility_meter -workday -yamaha -yamaha_musiccast" PYTHON_TARGETS="python3_9 (-python3_10) -python3_8"
    ^                           ^^^^^^
``` Calculating dependencies... done! [ebuild U ] dev-python/google-api-core-2.0.1::gentoo [1.31.2::gentoo] USE="-test" PYTHON_TARGETS="python3_9 -python3_8" 132 KiB Total: 1 package (1 upgrade), Size of downloads: 132 KiB !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-python/google-api-core:0 (dev-python/google-api-core-2.0.1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -python3_8" pulled in by dev-python/google-api-core (Argument) (dev-python/google-api-core-1.31.2:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_9 -python3_8" pulled in by ~dev-python/google-api-core-1.31.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (app-misc/homeassistant-min-2021.10.0:0/0::HomeAssistantRepository, installed) USE="accuweather airly airvisual alpha_vantage android_ip_webcam androidtv bluetooth_le_tracker caldav cast cli coronavirus dwd_weather_warnings github homekit homekit_controller http kodi mobile_app mqtt myq mysql notify_events otp ping python_script recorder rest ring scrape snmp speedtestdotnet sql ssl systemd systemmonitor tile tplink version wake_on_lan wemo whois zeroconf zwave_js -axis -camera -co2signal -compensation -darksky -enigma2 -esphome -forecast_solar -fronius -hyperion -influxdb -knx -kraken -maxcube -mikrotik -mysensors -owntracks -ozw -plex -ps4 -qnap -qvr_pro -samsungtv -season -shelly -signal_messenger -socat -sonos -tasmota -test -tradfri -utility_meter -workday -yamaha -yamaha_musiccast" PYTHON_TARGETS="python3_9 (-python3_10) -python3_8" ^ ^^^^^^ ```
onkelbeh self-assigned this 2 months ago
onkelbeh closed this issue 2 months ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.