HomeAssistantRepository/net-misc/yt-dlp/yt-dlp-2023.11.16.ebuild
Andreas Billmeier 0cfe92e62b
net-misc/yt-dlp: add 2024.09.27 (from main)
Closes: #3886
Signed-off-by: Andreas Billmeier <b@edevau.net>
2024-10-25 23:25:00 +02:00

73 lines
2.1 KiB
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{11..13} )
inherit bash-completion-r1 distutils-r1 optfeature wrapper
DESCRIPTION="youtube-dl fork with additional features and fixes"
HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
SRC_URI="https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"
LICENSE="Unlicense"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
RDEPEND="
dev-python/pycryptodome[${PYTHON_USEDEP}]
!net-misc/youtube-dl[-yt-dlp(-)]
"
distutils_enable_tests pytest
src_prepare() {
distutils-r1_src_prepare
# adjust requires for pycryptodome and optional dependencies (bug #828466)
sed -ri requirements.txt \
-e "s/^(pycryptodome)x/\1/" \
-e "/^(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d" || die
}
python_test() {
local EPYTEST_DESELECT=(
# fails with FEATURES=distcc, bug #915614
test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
)
epytest -m 'not download'
}
python_install_all() {
dodoc README.md Changelog.md supportedsites.md
doman yt-dlp.1
dobashcomp completions/bash/yt-dlp
insinto /usr/share/fish/vendor_completions.d
doins completions/fish/yt-dlp.fish
insinto /usr/share/zsh/site-functions
doins completions/zsh/_yt-dlp
rm -r "${ED}"/usr/share/doc/yt_dlp || die
make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
}
pkg_postinst() {
optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
has_version media-video/atomicparsley || # allow fallback but don't advertise
optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
elog 'as "youtube-dl". This is strictly for compatibility and it is'
elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
fi
}